$re = '/^The (\S+) ball is \1\.$/m';
$str = 'The red ball is red.
The soft ball is soft.
The batman ball is batman.
The batman ball is batmane.
The batman balls is batman.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);