const regex = /The previous system shutdown at [\w\s\-:\?\d\/]* was unexpected. for \S*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('The previous system shutdown at [\\w\\s\\-:\\?\\d\\\/]* was unexpected. for \\S*', '')
const str = `This is text with something in the middle of it like The previous system shutdown at 12:24:41 AM on ?2/?2/?2025 was unexpected. for MDO-SQL and we will ignore all the stuff before and I after it. `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}