re = /The previous system shutdown at [\w\s\-:\?\d\/]* was unexpected. for \S*/
str = 'This is text with something in the middle of it like The previous system shutdown at 12:24:41 AM on ?2/?2/?2025 was unexpected. for MDO-SQL and we will ignore all the stuff before and I after it. '
# Print the match result
str.match(re) do |match|
puts match.to_s
end