// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"The previous system shutdown at [\w\s\-:\?\d\/]* was unexpected. for \S*").unwrap();
let string = "This is text with something in the middle of it like The previous system shutdown at 12:24:41 AM on ?2/?2/?2025 was unexpected. for MDO-SQL and we will ignore all the stuff before and I after it. ";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}