use strict;
my $str = 'This is text with something in the middle of it like The previous system shutdown at 12:24:41 AM on ?2/?2/?2025 was unexpected. for MDO-SQL and we will ignore all the stuff before and I after it. ';
my $regex = qr/The previous system shutdown at [\w\s\-:\?\d\/]* was unexpected. for \S*/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}