using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:Mo|Tu|We|Th|Fr|Sa|Su)+)\s*[\d: PM-]{17}";
string input = @"MoWe 04:30PM - 05:50PM
Fr 12:00PM - 01:20PM";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}