$re = '/((?:Mo|Tu|We|Th|Fr|Sa|Su)+)\s*[\d: PM-]{17}/';
$str = 'MoWe 04:30PM - 05:50PM
Fr 12:00PM - 01:20PM';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);