re = /((?:Mo|Tu|We|Th|Fr|Sa|Su)+)\s*[\d: PM-]{17}/
str = 'MoWe 04:30PM - 05:50PM
Fr 12:00PM - 01:20PM'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end