const regex = /((?:Mo|Tu|We|Th|Fr|Sa|Su)+)\s*[\d: PM-]{17}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:Mo|Tu|We|Th|Fr|Sa|Su)+)\\s*[\\d: PM-]{17}', 'g')
const str = `MoWe 04:30PM - 05:50PM
Fr 12:00PM - 01:20PM`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}