import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:Mo|Tu|We|Th|Fr|Sa|Su)+)\\s*[\\d: PM-]{17}";
final String string = "MoWe 04:30PM - 05:50PM\n"
+ "Fr 12:00PM - 01:20PM";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}