package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?:Mo|Tu|We|Th|Fr|Sa|Su)+)\s*[\d: PM-]{17}`)
var str = `MoWe 04:30PM - 05:50PM
Fr 12:00PM - 01:20PM`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}