#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?:#Scene 1#)\s*(.*?)\s*(?:#Scene 2#)"
Local $sString = "#Scene 1#" & @CRLF & _
"Bernardo: Who's there?" & @CRLF & _
"Francisco: Nay, answer me: stand, and unfold yourself." & @CRLF & _
"" & @CRLF & _
"#Scene 2#" & @CRLF & _
"Horatio: Tis now struck twelve; get thee to bed, Francisco." & @CRLF & _
"Marcellus: Peace, break thee off; look, where it comes again!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")