package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(?:#Scene 1#)\s*(.*?)\s*(?:#Scene 2#)`)
var str = `#Scene 1#
Bernardo: Who's there?
Francisco: Nay, answer me: stand, and unfold yourself.
#Scene 2#
Horatio: Tis now struck twelve; get thee to bed, Francisco.
Marcellus: Peace, break thee off; look, where it comes again!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}