import re
regex = re.compile(r"(?:#Scene 1#)\s*(.*?)\s*(?:#Scene 2#)", flags=re.DOTALL)
test_str = ("#Scene 1#\n"
"Bernardo: Who's there?\n"
"Francisco: Nay, answer me: stand, and unfold yourself.\n\n"
"#Scene 2#\n"
"Horatio: Tis now struck twelve; get thee to bed, Francisco.\n"
"Marcellus: Peace, break thee off; look, where it comes again!")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")