re = /(?:#Scene 1#)\s*(.*?)\s*(?:#Scene 2#)/
str = '#Scene 1#
Bernardo: Who\'s there?
Francisco: Nay, answer me: stand, and unfold yourself.
#Scene 2#
Horatio: Tis now struck twelve; get thee to bed, Francisco.
Marcellus: Peace, break thee off; look, where it comes again!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end