import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:#Scene 1#)\\s*(.*?)\\s*(?:#Scene 2#)";
final String string = "#Scene 1#\n"
+ "Bernardo: Who's there?\n"
+ "Francisco: Nay, answer me: stand, and unfold yourself.\n\n"
+ "#Scene 2#\n"
+ "Horatio: Tis now struck twelve; get thee to bed, Francisco.\n"
+ "Marcellus: Peace, break thee off; look, where it comes again!";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}