$re = '/(?:#Scene 1#)\s*(.*?)\s*(?:#Scene 2#)/s';
$str = '#Scene 1#
Bernardo: Who\'s there?
Francisco: Nay, answer me: stand, and unfold yourself.
#Scene 2#
Horatio: Tis now struck twelve; get thee to bed, Francisco.
Marcellus: Peace, break thee off; look, where it comes again!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);