#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)http://(www\.)?(schema\.org|stackoverflow\.com|opensource\.org|php\.net|(?:[a-zA-Z]{2}\.)?wikipedia\.org|fsf\.org|creativecommons\.org|github\.com|getbootstrap\.com|mozilla\.org|firefox\.com|opera\.com|google\.com|bing\.com|yahoo\.com|apple\.com|microsoft\.com)"
Local $sString = "http://schema.org/" & @CRLF & _
"http://getbootstrap.com/" & @CRLF & _
"http://github.com/" & @CRLF & _
"" & @CRLF & _
"http://wikipedia.org" & @CRLF & _
"http://www.wikipedia.org" & @CRLF & _
"http://en.wikipedia.org"
Local $sSubst = "https://\1\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)