// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)http://(www\.)?(schema\.org|stackoverflow\.com|opensource\.org|php\.net|(?:[a-zA-Z]{2}\.)?wikipedia\.org|fsf\.org|creativecommons\.org|github\.com|getbootstrap\.com|mozilla\.org|firefox\.com|opera\.com|google\.com|bing\.com|yahoo\.com|apple\.com|microsoft\.com)").unwrap();
let string = "http://schema.org/
http://getbootstrap.com/
http://github.com/
http://wikipedia.org
http://www.wikipedia.org
http://en.wikipedia.org";
let substitution = "https://\\1\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}