package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)http://(www\.)?(schema\.org|stackoverflow\.com|opensource\.org|php\.net|(?:[a-zA-Z]{2}\.)?wikipedia\.org|fsf\.org|creativecommons\.org|github\.com|getbootstrap\.com|mozilla\.org|firefox\.com|opera\.com|google\.com|bing\.com|yahoo\.com|apple\.com|microsoft\.com)`)
var str = `http://schema.org/
http://getbootstrap.com/
http://github.com/
http://wikipedia.org
http://www.wikipedia.org
http://en.wikipedia.org`
var substitution = "https://\1\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}