const regex = new RegExp('http://(www\\.)?(schema\\.org|stackoverflow\\.com|opensource\\.org|php\\.net|(?:[a-zA-Z]{2}\\.)?wikipedia\\.org|fsf\\.org|creativecommons\\.org|github\\.com|getbootstrap\\.com|mozilla\\.org|firefox\\.com|opera\\.com|google\\.com|bing\\.com|yahoo\\.com|apple\\.com|microsoft\\.com)', 'gmi')
const str = `http://schema.org/
http://getbootstrap.com/
http://github.com/
http://wikipedia.org
http://www.wikipedia.org
http://en.wikipedia.org`;
const subst = `https://\1\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);