#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b[A-Z][0-9]+[A-Z][0-9]+\b\s*|\.srt[^\r\n]*"
Local $sString = "Something S01E01 Hello There Guys.srt" & @CRLF & _
"Something_else S03E22 Good.bye.srt" & @CRLF & _
"Something S01098E0109808 Hello There Guys.srt " & @CRLF & _
"Something_else S03E22 Good.bye.srt "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)