const regex = /\b[A-Z][0-9]+[A-Z][0-9]+\b\s*|\.srt[^\r\n]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[A-Z][0-9]+[A-Z][0-9]+\\b\\s*|\\.srt[^\\r\\n]*', 'gm')
const str = `Something S01E01 Hello There Guys.srt
Something_else S03E22 Good.bye.srt
Something S01098E0109808 Hello There Guys.srt
Something_else S03E22 Good.bye.srt `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);