use strict;
my $str = 'Something S01E01 Hello There Guys.srt
Something_else S03E22 Good.bye.srt
Something S01098E0109808 Hello There Guys.srt
Something_else S03E22 Good.bye.srt ';
my $regex = qr/\b[A-Z][0-9]+[A-Z][0-9]+\b\s*|\.srt[^\r\n]*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";