// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b[A-Z][0-9]+[A-Z][0-9]+\b\s*|\.srt[^\r\n]*").unwrap();
let string = "Something S01E01 Hello There Guys.srt
Something_else S03E22 Good.bye.srt
Something S01098E0109808 Hello There Guys.srt
Something_else S03E22 Good.bye.srt ";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}