$re = '/\b[A-Z][0-9]+[A-Z][0-9]+\b\s*|\.srt[^\r\n]*/m';
$str = 'Something S01E01 Hello There Guys.srt
Something_else S03E22 Good.bye.srt
Something S01098E0109808 Hello There Guys.srt
Something_else S03E22 Good.bye.srt ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;