import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[A-Z][0-9]+[A-Z][0-9]+\\b\\s*|\\.srt[^\\r\\n]*";
final String string = "Something S01E01 Hello There Guys.srt\n"
+ "Something_else S03E22 Good.bye.srt\n"
+ "Something S01098E0109808 Hello There Guys.srt \n"
+ "Something_else S03E22 Good.bye.srt ";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}