const regex = /some\/([^\/]+)\/([^\/]+).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('some\\\/([^\\\/]+)\\\/([^\\\/]+).*', 'gm')
const str = `some/test/test1/test2/test3`;
const subst = `some/$1/$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);