import re
regex = re.compile(r"some\/([^\/]+)\/([^\/]+).*", flags=re.MULTILINE)
test_str = "some/test/test1/test2/test3"
subst = "some/$1/$2"
result = regex.sub(subst, test_str)
if result:
print(result)