$re = '/some\/([^\/]+)\/([^\/]+).*/m';
$str = 'some/test/test1/test2/test3';
$subst = "some/$1/$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;