re = /some\/([^\/]+)\/([^\/]+).*/m
str = 'some/test/test1/test2/test3'
subst = 'some/$1/$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result