use strict;
my $str = 'some/test/test1/test2/test3';
my $regex = qr/some\/([^\/]+)\/([^\/]+).*/mp;
my $subst = 'some/$1/$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";