// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)some\/([^\/]+)\/([^\/]+).*").unwrap();
let string = "some/test/test1/test2/test3";
let substitution = "some/$1/$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}