#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(src=")(.+)(.jpg|.JPG|.PNG|.png|.JPEG)""
Local $sString = "img alt="Alt text" src="/directory/Images/my-image.jpg" />" & @CRLF & _
"img alt="Alt text" src="/directory/Images/my-image.png" />" & @CRLF & _
"img alt="Alt text" src="/directory/Images/my-image.PNG" />" & @CRLF & _
"img alt="Alt text" src="/directory/Images/my-image.JPEG" />" & @CRLF & _
"<script type="text/javascript" async="" src="https://www.google-analytics.com/analytics.js"></script>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")