$re = '/(src=")(.+)(.jpg|.JPG|.PNG|.png|.JPEG)"/m';
$str = 'img alt="Alt text" src="/directory/Images/my-image.jpg" />
img alt="Alt text" src="/directory/Images/my-image.png" />
img alt="Alt text" src="/directory/Images/my-image.PNG" />
img alt="Alt text" src="/directory/Images/my-image.JPEG" />
<script type="text/javascript" async="" src="https://www.google-analytics.com/analytics.js"></script>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);