const regex = /(src=")(.+)(.jpg|.JPG|.PNG|.png|.JPEG)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(src=")(.+)(.jpg|.JPG|.PNG|.png|.JPEG)"', 'gm')
const str = `img alt="Alt text" src="/directory/Images/my-image.jpg" />
img alt="Alt text" src="/directory/Images/my-image.png" />
img alt="Alt text" src="/directory/Images/my-image.PNG" />
img alt="Alt text" src="/directory/Images/my-image.JPEG" />
<script type="text/javascript" async="" src="https://www.google-analytics.com/analytics.js"></script>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}