import Foundation
let pattern = #"(src=")(.+)(.jpg|.JPG|.PNG|.png|.JPEG)""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
img alt="Alt text" src="/directory/Images/my-image.jpg" />
img alt="Alt text" src="/directory/Images/my-image.png" />
img alt="Alt text" src="/directory/Images/my-image.PNG" />
img alt="Alt text" src="/directory/Images/my-image.JPEG" />
<script type="text/javascript" async="" src="https://www.google-analytics.com/analytics.js"></script>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)