import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(src=\")(.+)(.jpg|.JPG|.PNG|.png|.JPEG)\"";
final String string = "img alt=\"Alt text\" src=\"/directory/Images/my-image.jpg\" />\n"
+ "img alt=\"Alt text\" src=\"/directory/Images/my-image.png\" />\n"
+ "img alt=\"Alt text\" src=\"/directory/Images/my-image.PNG\" />\n"
+ "img alt=\"Alt text\" src=\"/directory/Images/my-image.JPEG\" />\n"
+ "<script type=\"text/javascript\" async=\"\" src=\"https://www.google-analytics.com/analytics.js\"></script>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}