// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(src=")(.+)(.jpg|.JPG|.PNG|.png|.JPEG)""#).unwrap();
let string = "img alt=\"Alt text\" src=\"/directory/Images/my-image.jpg\" />
img alt=\"Alt text\" src=\"/directory/Images/my-image.png\" />
img alt=\"Alt text\" src=\"/directory/Images/my-image.PNG\" />
img alt=\"Alt text\" src=\"/directory/Images/my-image.JPEG\" />
<script type=\"text/javascript\" async=\"\" src=\"https://www.google-analytics.com/analytics.js\"></script>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}