# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\b|\^(?:OR|AND)?)(name|first_name|last_name|city)\b/$1user.$2/g;t' <<< "city=Houston^ORlast_name=Cervantsz^ORfirst_name=John^name=don"