import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\b|\\^(?:OR|AND)?)(name|first_name|last_name|city)\\b";
final String string = "city=Houston^ORlast_name=Cervantsz^ORfirst_name=John^name=don";
final String subst = "$1user.$2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}