import Foundation
let pattern = #"(\b|\^(?:OR|AND)?)(name|first_name|last_name|city)\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"city=Houston^ORlast_name=Cervantsz^ORfirst_name=John^name=don"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1user.$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)