$re = '/(\b|\^(?:OR|AND)?)(name|first_name|last_name|city)\b/';
$str = 'city=Houston^ORlast_name=Cervantsz^ORfirst_name=John^name=don';
$subst = "$1user.$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;