import re
regex = re.compile(r"(\b|\^(?:OR|AND)?)(name|first_name|last_name|city)\b")
test_str = "city=Houston^ORlast_name=Cervantsz^ORfirst_name=John^name=don"
subst = "$1user.$2"
result = regex.sub(subst, test_str)
if result:
print(result)