use strict;
my $str = 'To: John Lennon <John.Lennon@gmail.com> \\b002; Paul McCartney <Paul.McCartney@yahoo.com> \\b002;';
my $regex = qr/(?:\b[Tt]o:|\\b002;)\s*(.+?)\s*<[^<>@]+@[^<>@]+>/mip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";