import re
regex = re.compile(r"(?:\b[Tt]o:|\\b002;)\s*(.+?)\s*<[^<>@]+@[^<>@]+>", flags=re.MULTILINE | re.IGNORECASE)
test_str = "To: John Lennon <John.Lennon@gmail.com> \\b002; Paul McCartney <Paul.McCartney@yahoo.com> \\b002;"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)