// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(?:\b[Tt]o:|\\b002;)\s*(.+?)\s*<[^<>@]+@[^<>@]+>").unwrap();
let string = "To: John Lennon <John.Lennon@gmail.com> \\b002; Paul McCartney <Paul.McCartney@yahoo.com> \\b002;";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}