$re = '/(?:\b[Tt]o:|\\\\b002;)\s*(.+?)\s*<[^<>@]+@[^<>@]+>/mi';
$str = 'To: John Lennon <John.Lennon@gmail.com> \\b002; Paul McCartney <Paul.McCartney@yahoo.com> \\b002;';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;