#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?!.*googlebot).*(?:bot|crawl|spider)"
Local $sString = "Googlebot/2.1 (+http://www.google.com)" & @CRLF & _
"" & @CRLF & _
"Googlebot/2.1 (+http://www.google.com/bot.html)" & @CRLF & _
"" & @CRLF & _
"KHTML, like Gecko; compatible; bingbot" & @CRLF & _
"" & @CRLF & _
"KHTML, like Gecko; compatible; something Else" & @CRLF & _
"" & @CRLF & _
"KHTML, like Gecko; compatible; spider" & @CRLF & _
"" & @CRLF & _
"Googlebot/2.1 (+http://www.google.com) spider" & @CRLF & _
"" & @CRLF & _
"Googlebot/2.1 (+http://www.google.com) crawl" & @CRLF & _
"" & @CRLF & _
"Google bot/2.1 (+http://www.google.com)" & @CRLF & _
"" & @CRLF & _
"bot spider crawl Googlebot/2.1 (+http://www.google.com)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")