import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*googlebot).*(?:bot|crawl|spider)";
final String string = "Googlebot/2.1 (+http://www.google.com)\n\n"
+ "Googlebot/2.1 (+http://www.google.com/bot.html)\n\n"
+ "KHTML, like Gecko; compatible; bingbot\n\n"
+ "KHTML, like Gecko; compatible; something Else\n\n"
+ "KHTML, like Gecko; compatible; spider\n\n"
+ "Googlebot/2.1 (+http://www.google.com) spider\n\n"
+ "Googlebot/2.1 (+http://www.google.com) crawl\n\n"
+ "Google bot/2.1 (+http://www.google.com)\n\n"
+ "bot spider crawl Googlebot/2.1 (+http://www.google.com)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}